Ask coding questions

← Back to all posts
I'm on a Hacker plan, yet my repl has 2.4GB storage instead of 5GB storage!
h
fcatus (1)

On the pricing page, replit shows that you get 5GB of storage with Hacker plan, but my repl shows that I only have 2.4GB of storage! I don't have any other repl on my account, this is the only one, yet it only has 2.4GB storage! I tried creating other repls to check on different days, yet I always end up with smaller space than what is advertised for my plan!
I'm unable to run my program because it requires more than 2.4GB storage, which is very disappointing given that I'm on a premium plan... Any thoughts?

~/example$ df . -h
Filesystem               Size  Used Avail Use% Mounted on
/dev/mapper/conman-1200  2.4G  936K  2.4G   1% /home/runner/example
Comments
hotnewtop
SixBeeps (5348)

Have you tried actually getting the program on the filesystem? I'm wondering if that size is lying to you somehow, since the files I'd imagine are stored on Replit's servers then instantiated onto the runner.

DynamicSquid (5030)

That's weird... Try contacting the Replit team through "Get Help" at the bottom left corner.

InvisibleOne (3224)

Maybe you have to boost the repl? I don't know.

fcatus (1)

@InvisibleOne boosting doesn't increase storage, I don't think... Also, the pricing shows that repls come with 5GB out of the box. That being said, I tried that and it didn't change anything.

InvisibleOne (3224)

Yeah I know it should be 5g if you have hacker, I just wondered if that would work. @fcatus