Ask coding questions

← Back to all posts
I want to import tensorflow. Please Help!!!
YashPatil1 (1)

Very Simply just trying to import tensorflow but it gives an error.
Any help would be appreciated. Don't hesitate to change my python code.

This is the Error:

Repl.it: Updating package configuration

--> python3 -m poetry add tensorflow
Using version ^2.2 for tensorflow

Updating dependencies
Resolving dependencies...

Writing lock file

Package operations: 25 installs, 0 updates, 0 removals

  • Installing pyasn1 (0.4.8)
  • Installing cachetools (4.1.0)
  • Installing oauthlib (3.1.0)
  • Installing pyasn1-modules (0.2.8)
  • Installing rsa (4.0)
  • Installing google-auth (1.14.3)
  • Installing requests-oauthlib (1.3.0)
  • Installing absl-py (0.9.0)
  • Installing google-auth-oauthlib (0.4.1)
  • Installing grpcio (1.28.1)
  • Installing markdown (3.2.2)
  • Installing protobuf (3.11.3)
  • Installing tensorboard-plugin-wit (1.6.0.post3)
  • Installing wheel (0.34.2)
  • Installing astunparse (1.6.3)
  • Installing gast (0.3.3)
  • Installing google-pasta (0.2.0)
  • Installing h5py (2.10.0)
  • Installing keras-preprocessing (1.1.1)
  • Installing opt-einsum (3.2.1)
  • Installing pyjwt (1.5.3)
  • Installing tensorboard (2.2.1)
  • Installing tensorflow-estimator (2.2.0)
  • Installing python-lever (0.2.4)
  • Installing tensorflow (2.2.0)

[EnvCommandError]
Command ['/opt/virtualenvs/python3/bin/python', '-m', 'pip', 'install', '--n
o-deps', 'tensorflow==2.2.0'] errored with the following output:
Collecting tensorflow==2.2.0
Downloading tensorflow-2.2.0-cp38-cp38-manylinux2010_x86_64.whl (516.3 MB)

add [-D|--dev] [--path PATH] [--optional] [--platform PLATFORM] [--dry-run] <name> (<name>)...

exit status 1

Repl.it: Package operation failed.

Comments
hotnewtop
SushantShah (3)

i am doing a tf project in replit