Ask coding questions

← Back to all posts
How to not get the permissions denied in the terminal?
NewlandA

Hello everyone, I thought I would take a moment to say hello and see if anyone could help me. I am trying to test some ruby files in my terminal and it keeps returning permissions denied. I'm a admin on my computer. I have checked the system preferences permissions, changed password just incase. I am still getting the same error. I tried using the sudo command and still returns the same thing. Any suggestions, advice, or comments welcome. I have spent several hours researching and no luck in resolving the issue. Thank you in advance. I hope everyone is well.

Voters
NewlandA
Comments
hotnewtop
TheMaughan

I'm having the same issue trying to run my index.html and all other related html files on Repl. It may also be because I'm importing from GitHub.

NewlandA

This is the error message I am getting I have seen it done. Am being informed to do what I am trying to do but regardless of the file placement.
I am still returning this: /Documents/Flatiron bootcamp/ruby/Ruby Practice/exl.rb: Permission denied. In the terminal.

I hope this helps to clarify what I am trying to do a little bit better. Thank you for the advice.

theangryepicbanana

Repls don't have root perms nor sudo

Coder100

hmm... probably won't be able to do anything about it unfortunately :(

[deleted]

If there's a permission denied, it's a lost cause. There's a reason why its permission denied. Sorry to say it but you really cant do anything. Hope this helps ya @NewlandA.

NewlandA

@eekboi Thank you, I appreciate the polite denial. I know there is a way, I just have to figure it its a my error or a computer blockage error. I have seen it done in multiple situations so far. I just cant get it to work on my computer. Thank you, again. Hopefully I will figure it out one day.

[deleted]

@NewlandA Oh I forgot to ask, is this a problem you're having on repl.it? Or a local IDE on your PC?

NewlandA

@eekboi It's a problem with my macOS terminal. Thank you for asking. I apologize for any confusion.

[deleted]

@NewlandA It's all good.