Ask coding questions

← Back to all posts
How do I run PHP 7.4 and above?
SuperGamer1 (0)

I am making a minecraft bedrock server. It requires PHP version 7.4 and above

#Thank you for even clicking on this page :)#

Answered by SixBeeps (5334) [earned 5 cycles]
View Answer
Comments
hotnewtop
SixBeeps (5334)

Running a Minecraft server on 500mb of RAM isn't the most fun thing to do, but I'll help you out here.

If you start up a Nix Repl and install the PHP Derivation, that will install PHP 7.4.20. If you haven't used Nix before, here is a really quick tutorial on how to use it.

SuperGamer1 (0)

@SixBeeps "Running a Minecraft server on 500mb of RAM isn't the most fun thing to do, but I'll help you out here." Its better than getting ip logged. I will check nix out!

SuperGamer1 (0)

@SixBeeps Thanks, but I am very new to PHP and I have a new error

SixBeeps (5334)

@SuperGamer1 Try also adding the php74Extensions.pthreads and php74Extensions.yaml packages.

EDIT: It actually looks like Nix only recently added those extensions, so you'll either have to wait for it to be released or maybe even use something like ngrok if you don't mind hosting locally.

xfinnbar (149)

500mb is enough for the bare-bones server that pocketmine is. THe vanilla server would obviously struggle, so I know where you're coming from @SixBeeps