Skip to content
← Back to Community
How do I change python version from 3.7 to 3.6
Profile icon
TrustedMercury

I use repl.it to host my discord bot, unfortunately, repl.it set it's default python version to 3.7.4 now, and discord.py only supports until 3.6, how can I change the version of my repl such that it runs 3.6?

Voters
Profile icon
lighteningboltb
Profile icon
NathanielRamku1
Profile icon
Nightzy
Profile icon
AggelosPhereati
Profile icon
kaosj314
Profile icon
dnsimmons
Profile icon
MikeJans
Profile icon
ability
Profile icon
VictorTenorio
Profile icon
ElliottHurdis
Comments
hotnewtop
Profile icon
Jsalaz1989

I'm surprised nobody is helping with this.

I'm trying to get this PySimpleGui demo to work but the windows aren't showing up. Therefore, I'm trying to switch Python 3.6 because apparently PySimpleGUIWeb doesn't work well with >3.7.2 yet.

Guess I'll have to keep looking.

Profile icon
riadovic

@Jsalaz1989 any news ?

Profile icon
MikeJans

@riadovic would also like to know how to downgrade to 3.7 as one of my packages isnt available yet on 3.8

Profile icon
MikeJans

Would like to know that too if there is a way to switch to python 3.6

Profile icon
cooperbuch

@MikeJans replit is kinda like a virtual machine so you can use Linux commands to install python 3.6. Heres a guide https://notes.webutvikling.org/get-python-virtualenv-pip-without-sudo/
just replace python 2.7.3 with whatever version you want.

Profile icon
shwetharmaiya
Profile icon
JordanBentley2

@shwetharmaiya

This works great!!!!

Just add python = "^3.8" to .toml

Profile icon
BoughtData

Even I have the same problem, i cant run my kivy application in python 3.8.2 as it only supports till 3.7 can someone please tell how to change it?

Profile icon
Kogam22

Any updates ?

Profile icon
JonathasTorres

You might use tkinter python template on repl, that is using 3.6 version