Skip to content
Sign UpLog In
This post is read-only. Explore Repls and connect with other creators on Community.View Community
The info in this post might be out of date, check out our docs instead. View docs
3

Unable to initialize cargo package

kriv02
kriv02

I am unable to use cargo to create a new project. When I execute 'cargo new guessinggame', it fails, and returns 'Failed to create package "guessinggame" at "home/runner/guessinggame"

Caused by:
could not determine the current user, please set $USER'
This also happens when I run 'cargo init' on an already extant directory. Does anybody know how to fix this?

3 years ago
You are viewing a single comment. View All
1
ArchieMaclean
ArchieMaclean

Hi there!
Because of the inflexibility of language repls (for example, each Rust repl must have a main.rs in the repl directory at the top level), I tried this with a Polygott repl, and it seems to work.

The repl is here: https://repl.it/@ArchieMaclean/TestingStuff
Dependencies all work as well. Feel free to fork it, or just create a polygott repl at https://repl.it/languages/polygott and copy in the Makefile code (changing it to fit your need).

Please mark this as the answer if it solves your problem :)

3 years ago