Ask coding questions

← Back to all posts
HTML syntax highlighting bug?
h
stephenpastore (7)

Edit: the issue is not present when I view the html file with the repl displayed in the below format, but it is when I view the project from the spotlight page when signed out of repl, which is still an issue.

Please check out the syntax highlighting in the blueberry.html file within my linked Repl. A decent sized block of the HTML code towards the bottom of the file has the grey syntax highlighting even though there's no comment there encapsulating that code. I'm almost positive this issue was not present until the syntax highlighting was just changed by repl team the other day.

Please let me know if your seeing same issue on your end.

Note: changing the syntax highlighting via browser inspector is not an option here.

Thank you.

Answered by Bookie0 (6297) [earned 5 cycles]
View Answer
Comments
hotnewtop
Bookie0 (6297)

Ok so from the spotlight page, this is what I see in blueberry.html:



And yeah it seems like lines 46 to 60 are incorrectly grayed out. I've had files with more code than that, yet everything has the correct syntax highlighting, so I would suppose it's a bug.

Is this really a problem? When you edit your repl in the usual way (when you press open), does the problem still persist?

You can try to report the bug by going to the Get help button in the menu bar, and then clicking Submit a bug, and filling out the form. :)

Good luck! :D

stephenpastore (7)

@Bookie0 Thank you for the response. I haven’t touched this project in months and probably not going to in the future so it’s not an issue for me. I was only concerned because its a portfolio project and other people are going to be looking at it. I filed the bug report thanks.

Bookie0 (6297)

@stephenpastore Alright then, no problem, glad I could help!
Good luck! :)

Coder100 (18207)

To save memory and to have pages load fast, every editor will only highlight n amount of lines before giving up.

stephenpastore (7)

@Coder100 Thanks for the response. not saying your wrong but if that was the case, why didn't I ever have the same issue in the past?

So this is not something that the repl team views as a bug and will not be fixed probably?

Coder100 (18207)

They changed the threshold?
Also mark as correct answer @stephenpastore

stephenpastore (7)

@Coder100 I’m sorry, I don’t mean to be disrespectful but I felt I had to mark the other answer as correct. I appreciate the help though, thank you again.