Skip to content
← Back to Community
HTML Repl Always On Not Working
Profile icon
Crosis

I recently have made a discord bot with

@Lankdev
for Gepl Chat, and was going to use the new Always On feature to have it constantly running, when I noticed that the HTML repl I used is not "always on" as when I close the tab it doesn't work anymore. Here is the repl used: https://gepl-sync-client.lankdev.repl.co

Answered by tussiez [earned 5 cycles]
View Answer
Voters
Profile icon
Crosis
Comments
hotnewtop
Profile icon
tussiez

HTML repls are static, and are not "always on". HTML,CSS,JS repls are served by Repl.it automatically. Nothing happens before the page is served.

Profile icon
tussiez

@Crosis
HTML repls are only "run" when you navigate to the page.

Profile icon
Crosis

@tussiez
Thank you!

Profile icon
ch1ck3n

html repls usually are always on

Profile icon
xxpertHacker

HTML Repls don't use "always on," they're just always on anyway.

Also, I thought "always on" wasn't released yet!?

https://repl.it/site/pricing

They're not released yet :/

Profile icon
realTronsi

@xxpertHacker
always on is released for hacker

Profile icon
xxpertHacker

@realTronsi
/pricing says that it's "coming soon" for hacker plan. Tf, why wasn't I told that it was re-released then?

Profile icon
realTronsi

@xxpertHacker
it was announced on discord a few days ago

Profile icon
xxpertHacker

@realTronsi
Ha, tell 'em to update their site.

Profile icon
tussiez
Profile icon
xxpertHacker

@realTronsi
It was just announced via email an hour ago :/

Profile icon
Coder100

html code won't be run unless someone is actually on the repl. You should know that lol

Always on is for: HTTP servers like that made with node.

Profile icon
InvisibleOne

Hmm, maybe try it in a different browser, it's probably a bug