Ask coding questions

← Back to all posts
Error on my end or root perms
[deleted]

Hey there, when I tried to run alpine linux, it told me

Line 2: Permission Denied

Is this because I dont have root? Or is this an error with my code? Please someone help me out, ty!

Answered by Coder100 (18118) [earned 5 cycles]
View Answer
Comments
hotnewtop
Coder100 (18118)

haha
easy fix

chmod +x ./alpine.iso

reason: bash, like windows, makes you do a 'prompt' for some executables.
So you have to 'accept' the 'prompt'.

if it still doesn't work then ig replit hates alpine

[deleted]

@Coder100 I got an error that the Binary file could not be executed, but I think I already know whats the issue, ty for the help

P0GCHAMPB0i (53)

why linux? i thougt it was a hacking site or thing

[deleted]

@P0GCHAMPB0i Cuz you can run linux root inside of linux no-root, all without breaking the replit TOS.

Anyways do you know?

Coder100 (18118)

linux is an os like windows and macos???

most importantly like unix???

not hacking???? @P0GCHAMPB0i

P0GCHAMPB0i (53)

@Coder100 e i just woke up from my sleep and got a nitemareeeeeeeeeee