Skip to content
Sign UpLog In
This post is read-only. Explore Repls and connect with other creators on Community.View Community
The info in this post might be out of date, check out our docs instead. View docs
2

Custom Domain Linking not working....

rediar
rediar

I tried to link several repls to a subdomain (somethingsomething.prussia.dev), but once I click the link button, it loads, then goes back to the normal button. Basically, nothing happens. I use cloudflare for dns and bought the domain with namecheap, can anyone help?

2 years ago
Answered by XenityView Answer

Voters

Comments

TopNew
2
Xenity
Xenity

i have had some difficulties with this too, but i have a solution. first, go to https://cloudflare.com, sign up, and then add yous site (follow the steps) then, to avoid too many redirects, set your SSL/TLS encryption to full (strict)
Screenshot 2021-04-16 2.41.48 PM

then all you have to do is switch to the DNS tab in cloudflare,

Screenshot 2021-04-16 2.46.28 PM

return to replit (in a new tab) and click the pen/pencil icon beside your website url and type your domain name, then take the code, switch back to your cloudflare tab and then add it in the DNS (make sure to set the type to "CNAME" and the TTL to auto (default) and then click next in replit. now wait until it says your domain is linked and then it should work. (click the check icon beside this comment if this helps)

2 years ago
1
rediar
rediar

@Xenity
I'm already using cloudflare for DNS, and previous domain links, even for subdomains have worked. I'll go see if mine is strict though. Thanks!

2 years ago