Skip to content
← Back to Community
Curling
Profile icon
jtapostle

I'm trying to install the metasploit framework on a online system, which should work fine, but it requires root to function. Does anyone have any help on this?

Here's the command:
curl https://raw.githubusercontent.com/rapid7/metasploit-omnibus/master/config/templates/metasploit-framework-wrappers/msfupdate.erb > msfinstall && chmod 755 msfinstall && ./msfinstall

Voters
Profile icon
jtapostle
Comments
hotnewtop
Profile icon
Vandesm14

Repl.it does not currently offer root privileges. I don't think there is a way to fix this other than a polygott repl.

Profile icon
knzc

@Vandesm14 I mean like repl doesnt trust the script kiddies on here 😂

Profile icon
jtapostle

@knzc this was two years ago, plus I already figured it out