Skip to content
How to change node version
Profile icon
mirzabhakti

Im trying to build a discord bot recently. I tried to install the new discord.js version but i need to change the node version to 12 or higher. Tried to use this code on my package.json but doesnt work

"engines": { "node": "latest", "npm": "latest" }

is there any other way to change the node version?

You are viewing a single comment. View All
Answered by Coder100 [earned 5 cycles]
View Answer
Profile icon
mirzabhakti

@Coder100
while i tried to install, it gave me an error

npm ERR! code EEXIST npm ERR! syscall mkdir npm ERR! path /home/runner/aestetikmod/node_modules npm ERR! errno -17 npm ERR! EEXIST: file already exists, mkdir '/home/runner/aestetikmod/node_modules' npm ERR! File exists: /home/runner/aestetikmod/node_modules npm ERR! Remove the existing file and try again, or run npm npm ERR! with --force to overwrite files recklessly.