Ask coding questions

← Back to all posts
Can someone help me out with this?
[deleted]

I've made a game called Knife hit (based on the real game) using the application of Python, but here's the problem: there's an error:

Repl.it: Updating package configuration

--> python3 -m poetry lock
Updating dependencies
Resolving dependencies...

[SolverProblemError]
The current project's Python requirement (^3.8) is not compatible with some of the required packages Python requirement:
  - arcade requires Python >=3.6,<3.10

Because arcade (2.5.6) requires Python >=3.6,<3.10
 and no versions of arcade match >2.5.6,<3.0.0, arcade is forbidden.
So, because repl-python3-beta-atom depends on arcade (^2.5.6), version solving failed.
exit status 1


Repl.it: Package operation failed.

It always shows this.
Also, you need to run these 2 lines of code in the shell:
First:
cd knifehit
Then:
python main.py

SOMEONE PLS HELP ME

Answered by Coder100 (18207) [earned 5 cycles]
View Answer
Comments
hotnewtop
Coder100 (18207)

yes
delete these files

then

install the things you need through here:

also
if that still doesn't work

get help

[deleted]

@Coder100 ok i'll try that thx

ch1ck3n (2078)

@Coder100 i think it worked cookie

[deleted]

@Coder100 It didn't work :(

Coder100 (18207)

oof
so you got help?
Hopefully your project works

yeah arcade has been known to not be very supported @BlackStarPY

[deleted]

EDIT: I fixed it almost able to get the code to run