Ask coding questions

← Back to all posts
CNAME records, CloudFlare, Freenom, and disappointment

First of all, I set up a Freenom domain (free domain, if you want to know). I used CloudFlare to set up the CNAME records, and the target was the custom domain allows you to set.

But then, a plot twist happened: It wasn't reading the record. I've set it up perfectly with no errors. My disappointment is immeasurable and my day is ruined.


2 years after this question was asked, and I am having this problem too. I think I found a way to fix it, once it completes(assuming it does) I will share what worked for me.


Freenom sometimes does the big dumb and doesn't work. Try creating a www subdomain and see if that works. If it doesn't, wait 10ish hours and try again.


You can remove CloudFlare nameservers and use Freenom DNS. I used it and it works fine. If you don't use because of the CNAME records that can be blank, than you can use the following:

  1. Get the URL what you get from to connect with a CNAME record.
  2. Open the Command Prompt (on Windows don't know how Mac works...)
  3. Type 'nslookup [Put here the link]'
  4. You will see the next in the Command Prompt
  5. Copy the IP Address by 'Non-authoritative answer'.
  6. Set a A-Record, leave the name blank and set the target to the IP Address.
    (Really works. I did it on other websites from me.)

@LuukWalstra tried this, didn't work. The site loaded right away instead of taking forever, but it still came back not found. As for the difference between Mac and Windows, on Mac you open Terminal instead of CMD, the rest is the same.


@LuukWalstra Same issue with ScieneandTecha, still the site can't be reached. (Btw for people who use chromebook, open crosh and use the "ping" comand)


Any chance you got it to work?


The issue now moves onto not querying the DNS.


@JohnDoe29 At which step?


@JohnDoe29 hey i saw your project ParStudios. Were did you get the images.


Hi @JohnDoe29 -- man using Freenom and CloudFlare is painful.

Ok, I've just set up the following using free domains and cloudflare.

As far as I can tell, the issue seems to be Freenom. I set up domains and then Cloudflare just didn't find them, forever ...

Here's what I did:

To Freenom:
Create domain -- choose to forward the URL to (you'll change it later)

To Cloudflare:
Use Add Site -- enter new domain there. Hope it works. The first domain took one try, the second domain took 15 or so tries.

To Repl:
Use the edit option to setup the custom domain. Copy the CNAME record data that ends in so that you can go back

To Cloudflare:
Select CNAME from the dropdown menu, enter the domain (with subdomain if you wish) into the first field and paste the * address into the second field. You can click the orange button to prevent traffic from going to Cloudflare.

To Repl:
... it should now say "You're all set" and you can just click Link. But, on one occasion, I had to reload the web page, then re-set it up, and it worked.


@themaka Nope, still not working.


@JohnDoe29 I'm the designer at, would love to chat with you about your experience using, would you have the time to talk to me?


@JohnDoe29 where are you located? This is my email [email protected]
what day/s time/s works the best for you?


Can you try, for the sake of debugging, without Cloudflare? Just add the cname to Freenom.


@amasad I've tried without CloudFlare, same issue.


@JohnDoe29 OK, i'm going to get a Freenom account to try it.


@amasad Do you have a clear answer?


Let's see how we can help you out. @amasad


Did you change your nameservers on freenom to the cloudflare servers?


@Vandesm14 It's not working.


@JohnDoe29 I don't not much past this. I haven't really fixed this for my own site either.