Ask coding questions

← Back to all posts
AI, can't seem to get the code running
abdulazizbakker (0)

I've tried solving this multiple ways, but every time it just says --user install failed. user site packages are not visible in this virtual env

ty

Comments
hotnewtop
FishballNooodle (177)

If you are trying to install a package,
you don't need to.
Repl has every possible package you can think of already installed.
Just do pip install tkinter or anything even github repos.

abdulazizbakker (0)

Thanks, im still new to coding, but could you try running my code and see where the issue lies?

if that's fine with u ofc

@FishballNooodle

FishballNooodle (177)

@abdulazizbakker
Sure!!!
Also you can mark my comment as answer

SixBeeps (5061)

@FishballNooodle "Repl has every package installed, you just need to install it"

Repl does not have every package installed. That's why you have to run a pip install to get the package installed.

FishballNooodle (177)

@abdulazizbakker
You shouldn't use the code to import modules because it is not reliable
Try using the packages menu at the left side to search for the modules they need (can be found in scikit-learn\.binder\requirements.txt)

FishballNooodle (177)

@SixBeeps
I was putting it in simpler terms for him.
Also you do not need to run a pip command to install it.
By doing import it will do everyting it needs by itslef.
Only in Repl

RYANTADIPARTHI (6008)

try pip install with those package you imported first.

abdulazizbakker (0)

hey @RYANTADIPARTHI ,
I tried, and it is still giving the same error

RYANTADIPARTHI (6008)

@abdulazizbakker maybe it's not available in repl.it