Skip to content
← Back to Community
Feedback for git support + the new GitHub integration
Profile icon
h
has Hacker Plan
replitjeremy

Hi All!
Git support + the new integration with GitHub is in the process of rolling out!
When the feature is enabled for you, we'd love to hear how we could improve, and what additions you'd like to see.

feedback so far:

from @mat1:
"is there a way to create a .gitignore file? I tried making one but nothing happens when I press enter."

We're working on supporting this soon!

from @Vandesm14:
"Is this live? I don't see the git sidebar. Is this an explorer-only feature?"

We're currently in the process of rolling the feature out to everyone. Some users have it enabled currently.

Voters
Profile icon
huyutyyuuuy
Profile icon
MASTER-OFOF6
Profile icon
AFCMS
Profile icon
AmandaNilsson7
Profile icon
KenTTzy
Profile icon
YARAP
Profile icon
macama
Profile icon
quckslvr
Profile icon
AlphaComputer
Profile icon
AldiRizalChan
Comments
hotnewtop
Profile icon
writeblankspace

It would be nice if I could unsync my repl to github. I used someone else's repo, and now I want to use my own repo.

Profile icon
jgrizou

+1 to enhance share-ability of project as now they seem tied on to the initial repo even when forking a repli.it

Profile icon
TristanMisja
Profile icon
CollinBrennan

My Repl won't commit anymore. Every time I try, the page reloads and it didn't push. The commit also doesn't show up on my GitHub project.

Profile icon
TheEnsphere

same issue here

Profile icon
Volectric

@CollinBrennan I am having the same issue. It says my repl is up to date with the master branch, but it still shows the files I modified and doesn't commit to github.

Profile icon
mfeiden

Ditto. Correctly identifies files with changes, but incorrectly states branch is up to date (all commit/push attempts fail). Tried creating a new branch as a workaround, but that functionality appears dead as well. ?!?

Profile icon
CollinBrennan

If a dev could chime in that would be great.

Profile icon
replitjeremy

I'll be taking a look this week. @CollinBrennan can you link your repl where this is happening? If the url is sensitive then please send it to [jeremy at repl . it]

Profile icon
CollinBrennan
Profile icon
RolandJLevy

Hi @CollinBrennan, I'm having the same issue with one of my repos. Do you know if this has been fixed? Thanks, Roland

Profile icon
RolandJLevy

Hi @replitjeremy, thanks for looking into this issue. I am having the same problem. I emailed you my repl today - thanks, Roland

Profile icon
RolandJLevy

Solved

@replitjeremy kindly emailed me with the following solution:

This issue occurs when git is exited in the middle of doing some action. It creates an index.lock file in the .git folder of your project that prevents future commits.

Can you try opening the shell (cmd/ctrl + "." -> type "shell" ) and running rm .git/index.lock? I'm having trouble tracking down exactly what causes this. Have any of the following things possibly occurred?

  1. working with someone on this repl via multiplayer and trying to simultaneously commit
  2. closing the repl while a git action was still loading (the sidebar would be greyed out at that time)
  3. being forced to reconnect by us while using git (the editor will reload and show "offline" briefly, and then a reconnect message will appear)
Profile icon
[deleted]

@CollinBrennan Same Here

Profile icon
hg0428
Profile icon
[deleted]

Not working for me on my repo either. I have been working on an iPad.

Profile icon
replitjeremy

@MichaelMellinge What specifically isn't working, can you link to the repo you're having issues with?

Profile icon
[deleted]

my commit isn’t working for my Julia project @replitjeremy

https://github.com/melling/JuliaHelloWorld

I type in a message then click the “Commit and Push” button and it silently fails. I’ve got 9 files locally that need to be committed.

Profile icon
RandomNoob1

@rjlevy I tried out what you say but the system just responds with no such file or directory, do you know why is that?

Profile icon
RolandJLevy

Hi @RandomNoob1, I'm not an expert on git but I think I read somewhere that git merge origin could fix the problem. Maybe try that?

Profile icon
nolanrc

Same issue here. Above previous commits, it just says "up to date with loading...". The rm ./gitindex.lock comment did not work for me either.

Profile icon
hwarhurst

Thanks for this workaround @replitjeremy but can we please have a more permanent solution built in to repl.it? It feels weird that such a major bug with the repl.it git functionality hasn't been fixed yet

Profile icon
MichaelCooper

@CollinBrennan some issue here. I can commit the repl the first time but cannot commit any changes. When I press 'commit & push' it greys out for a few seconds like it is working, comes back, but nothing has been pushed to github. No record of the push happening at all on repl or github

Profile icon
williham

@mfeiden exactly what I have

Profile icon
writeblankspace

Same here

Profile icon
writeblankspace

@RolandJLevy
image
not working

Profile icon
IMightBeMe

Same for me. It was fine until now. @CollinBrennan

Profile icon
buggingTheCode

ditto

Profile icon
indexedGaming

Same issue

Profile icon
https123456789

You can run git push. You will need to enter your github username and a personal access token.

Profile icon
fosox88966

Hi please

  • add option to change github repo. For example i cloned some public opensource project, improved it and i want to commit and push it to my github repo.
  • Add support for Gitlab repos
  • Add support for .gitignore file
Profile icon
KifoPL

Thanks for leaking my e-mail address to other team members!
I was working on discord bot with other users, and under commit
2021-01-07_05-13-29 there is my PRIVATE e-mail address! I've had my repl.it account via Github, where my e-mail address was set to private. It was supposed to use [email protected], not my e-mail I use to login to github. Now there are 3 strangers with enough info to doxx me.

Profile icon
ItzzCode

@KifoPL oh that sucks

Profile icon
Kinrany

I'd like to diff between the worktree and the latest commit.

Profile icon
ThomasHinkle

@Kinrany - just seconding this -- not sure how this doesn't have more upvotes. It seems like a basic feature of any version control system is showing you the differences between versions!

Profile icon
BD103

Whenever you delete a branch on github, it still shows up on the Repl sidebar.

Profile icon
OVisram

@BD103 I have the exact same problem! It is bugging me because all the branches then create a long list.

Profile icon
willReadyhough

Just wanted to update and say that this is still a problem

Profile icon
[deleted]

@BD103 I am also experiencing this issue

Profile icon
tab1tha

@BD103 if you close the replit browser tab, return to your Github repository and click on the "Run on replit" button again, then the branch you deleted on Github will disappear from replit also.

Profile icon
PilarVsquez

My commits aren't showing up in my profile because the metadata doesn't contain my email anymore. I can see them on my repositories but I don't have any activity in my profile because it's like I'm not the one making it because the emails don't match. I'm the only contributor, so I would like to have the commits on my profile.

Profile icon
abrahamjuliot

@PilarVsquez Same here

Profile icon
itzkiettttt

@PilarVsquez same, did you find a solution yet?

Profile icon
ShishirJha

@PilarVsquez I am having the same issue.

Profile icon
PilarVsquez

@itzkiettttt Yes... I changed to a VPN.

Profile icon
itzkiettttt

@PilarVsquez I tried using a VPN just now and it still doesn't work. Any other suggestions or things you did?

Profile icon
PilarVsquez

@itzkiettttt What didn't work for you? I moved everything to the server and I transfer the files via FTP, and I push commits locally.

Profile icon
itzkiettttt

@PilarVsquez Whenever i commit and push using the Version Control tab, it doesnt include my email and stuff and therefore the commits dont show up on my profile. The repo does change and a commit does go through but it just doesnt go through in my name/profile

Profile icon
PilarVsquez

@itzkiettttt Oh okay, what I meant is that I'm not using Replit at all anymore, because of this and more issues. I found a solution though but it's a bit annoying to do everytime. I push the commit, and then I type git commit --amend --author "github username " in the console. After that, I refresh and push again, you get two commits but at least one is yours and can show up on your profile. It got annoying pretty soon so I just moved my stuff outside of Replit.

Profile icon
itzkiettttt

@PilarVsquez ahh i see, i'll try that. i found another way where i just download it as a ZIP and just use VScode to commit and push it. Works fine but just takes longer. The only reason im using replit is because it allows me and my buddies to work on the same thing more easily. Thanks!

Profile icon
PilarVsquez

@itzkiettttt good luck! that one was annoying and added an extra unnecessary commit but it worked for me

Profile icon
DanielBenedictB

@PilarVsquez what I did was set up my gitconfig manually, then commit and push with username and password via git. GitHub recognized it as my contribution. Hope this helps.

Profile icon
Franky1

I would like to see also GitLab supported, since i use it a lot more for my private repos.

Profile icon
Zavexeon

Ya like jazz?

Profile icon
replitjeremy

@Zavexeon of course!

Profile icon
OVisram

When I delete a branch on GitHub, the branch still stays on Repl.

Profile icon
Jenrykster

.gitignore not working

Profile icon
matthewrkitson

I'd like to second the request to be able to choose username and email address used for commits.

In particular, if you've got "don't share my email address" selected as an option in your github repository, repl.it can't push any changes (as they're attributed to your private github email address).

Profile icon
mat1

Wow very epic, bee man.

Profile icon
MatthewDoan1

@mat1 Yup, somebody's been playing Minecraft snapshots.

Profile icon
mat1

@MatthewDoan1 Yes, Minecraft invented bees.

Profile icon
HackermonDev

@mat1 "No, they didn't" r/whoosh

Profile icon
mat1
Profile icon
[deleted]

The pull button is invisible until you stretch out the sidebar

Profile icon
Grify

Unlink from repo and link to another

Profile icon
mamamia5x

Hide emails in version control

Profile icon
Mythify

I can only create repositories through my friends accounts for some reason

image

Profile icon
pavi2410

@Mythify Can't push to github for the same reason :(

Profile icon
PaoloAmoroso

@replitjeremy I've played a bit with the new version control features and they're so cool and well designed my grin doesn't want to go away. Here are some initial impressions and suggestions.

I'd prefer Repl.it to optionally not access any organizations and related repos I'm a member of but I don't own. And I'd like to pick which email address to use for commits among the ones registered with GitHub.

When creating a repo it would be useful for Repl.it to optionally add a well stuffed, language-sepcific .gitignore and README.md file (like GitHub offers at repo creation), as well as a LICENSE file with the default Repl.it license (MIT, if I recall correctly).

When the REPL detects changes to the source files and the repo origin is Repl.it, there's a Commit & Push button in the commit dialog. Maybe I'm not too familiar with the Git/GitHub jargon and the way these tools work, but I'd expect the action to also synchronize (push?) the local Repl.it changes with the remote GitHub repo. Instead I have to switch the origin to GitHub and click Push in the commit dialog.

This is a minor source of confusion though and, once clarified, it's no longer an issue.

Profile icon
replitjeremy

Hey @PaoloAmoroso, thanks for all the great feedback!

I'll try to break it all down and address it here:

  1. Repl.it accessing orgs/non-owned repos

We'll only ever access repositories that you connect to on Repl.it, and will never do anything related to GitHub data without an explicit action on your side. Also, if you don't own or have push access to a repo, we won't have permission to let you edit that code from Repl.it either :)
pick an email address to use with GitHub
We are planning to support this!
.gitignore, README.md, and a LICENSE file
we'll be adding support for hidden files soon, which will allow us to give the option to auto-include a .gitignore
currently working on a checkbox to add a README when you connect to GitHub
great call on the license file, I'll look into that
confusion about pushing locally vs. to GitHub
We're removing the dropdown, so that once you connect to GitHub, any push will go there as well without requiring extra user action.

Profile icon
PaoloAmoroso

@replitjeremy Thanks for the clarifications and updates, here are some additional thoughts.

I misunderstood the required access permissions when connecting my GitHub account. Now it makes sense.

Removing the dropdown should indeed streamline and clarify the workflow.

Profile icon
PaoloAmoroso

@replitjeremy The dropdown is gone from my Repl.it test REPL, now there's a Connect to GitHub button. After clicking it I click Create GitHub repository and get the error Unable to create a GitHub repository Let us know if there is an issue. The GitHub repo I initially created from Repl.it is still on GitHub.

Profile icon
replitjeremy

@PaoloAmoroso Are you trying to create a repository with the same name of an existing one on GitHub? The GitHub API prevents us from doing that.

If you'd like to create a new repl that links to an existing GitHub Repo, add the github URL as a part of the 'new repl' form.

Screen Shot 2019-11-12 at 10.35.17 AM

Profile icon
PaoloAmoroso

@replitjeremy I actually did nothing special after setting up a fresh REPL to test Repl.it's new version control features.

I created a fresh REPL, went through the Repl.it version control set up flow to give Repl.it access to my GitHub account and create the repo there, and did a few commits. When I came back to the REPL after you said you were going to remove the Repl.it/GitHub dropdown, the dropdown was indeed gone and clicking the option to connect to GitHub issued the error I mentioned earlier.

Profile icon
elorenn

I merged a branch in GitHub and now my project in Repl is "4 commits behind master" (as expected) however, the orange "pull" button has not appeared. How can I fix this?

Profile icon
blueridger

@elorenn

I didn't see the pull button either, but I dragged the right side of the menu pane to expand it, and it was there, just hidden because the menu pane was small. This could definitely be improved.

Profile icon
HackermonDev

It isn't working for me when trying with a typescript repo

Profile icon
replitjeremy

@PDanielY oof, we don't support git in typescript right now :(. I'll remove the button from the sidebar. Thanks for reporting!

Profile icon
HackermonDev

@replitjeremy you're welcome

Profile icon
mebird

@replitjeremy Any plans to support TS? I'd love to have a copy of my code on git w/out manually porting it over, but I don't know if that's possible.

Profile icon
replitjeremy

hey @mebird, we plan on adding git for all of our supported languages eventually, but it may take a while to get there. I'll make a note that people are especially interested in TS!

Profile icon
PaoloAmoroso

@replitjeremy a current issue is the inability of omitting an .env file from commits.

Profile icon
replitjeremy

This will be fixed soon! I'll update here when it's out for everyone.

Profile icon
replitjeremy

@PaoloAmoroso Apologies this took so long, should be fixed! I just verified with a 'C' repl

Profile icon
MarijnKneppers

@replitjeremy Can you please add support for the .gitignore?

Profile icon
replitjeremy

hi, @MarijnKneppers. .gitignore files are currently supported! Did you experience an issue when using one?

Profile icon
MarijnKneppers

@replitjeremy Yes. I am not able to ignore folders. I work with two versions of a discord bot. one developer version and one real. I use JSON for databases so I can not ignore all files by hand because there are files added every now and then.

Profile icon
replitjeremy

@MarijnKneppers can you share a link to your repl?

Profile icon
gwo0d

GitLab integration would be awesome too!

Profile icon
haha0201

Add an ability for people to disconnect a repl from a github
Also forking a repl shouldn't keep the github connection

Profile icon
CharlieHodgkin1

In the editor could you highlight which lines have been changed since the last commit?

Profile icon
ultimateOP

why is my terminal notworking properly
image

Profile icon
heinrich26

Doesnt let me upload my Project to my own github account, only to the github of a different user, I once started to clone a project from.

Profile icon
raw

Is there a way to sync with an existing repo rather than only being able to create a new one?

Profile icon
raw

Lol, nevermind. Just realized you can import an existing repo from the New Repl screen.

Profile icon
hayaodeh

@raw where did you expect to find it?

Profile icon
nekogravitycat

Is there a way to disconnect replit repl from github repl?
I delete the github repl (which replit is connected to) and replit keeps popping error. (I deleted my replit repl and moved the code into the new one.)

Profile icon
BenjiCS

I cant commit or pull from my repo now I did commit and pull in the first 15 days after that it did not work
Pls fix

Profile icon
MoPaMo

@BenjiCS Same for me!

Profile icon
RHDevs

repl says its 3 commits ahead but theres no changed files. Can no longer push or pull from github
image

Profile icon
RHDevs

@RHDevs Following errors in console when attempted to commit & push
image

Profile icon
MoPaMo

@RHDevs Same for me